Xcode hatası "Geliştiriciler üçün disk görünüşü tapılmadı"

Xcode'da bağlı bir iOS qurğusunda qurmağa çalışdığımda səhv mesajını alıram:

Geliştirici disk imici tapıla bilmədi

2019

09 июня '15 в 18:48 2015-06-09 18:48 Nathan Kramer 09 iyun 'da 18:48 ' də təyin olunub
@ 22 cavab

Xcode 7.3 və ya Xcodun daha əvvəlki versiyasında eyni problemə qoşdum və cihaz versiyamız OS əməliyyat sisteminizin iOS 10 və ya son versiyasıdır.

Bu səhv sizin Xcode köhnəldikdə göstərilir və istifadə etdiyiniz müvafiq cihaz ən son versiyaya yenilənir. Əvvəlcə Xcode-un ən son versiyasını yükləyin. Ən son Xcodu yükləməyə ehtiyac yoxdur.

Aşağıdakı addımları tamamlayaraq bu problemi həll edə bilərik:

  • Xcode 8 və ya Xcodunuzun daha yeni bir versiyasını sağa vurun, " Paket İçeriğini Göstər ", " İçerik ", " Developer ", " Platformlar ", " iPhoneOS.Platform ", " Qurğu Dəstəyi "
  • Klasörü 10.0 (və ya daha yeni bir versiya üçün daha yüksək) kopyalayın.
  • Axtarışa qayıdın, Applications (Applications) yenidən seçin.
  • " Xcode 7.3" və ya "Xcode" sürümünüzə sağ tıklayarak "Paket içeriğini göstər", "Content", "Developer", "Platformlar", "iPhoneOS.Platform", "Device Support"
  • 10.0 qovluğuna yapıştırın (daha sonra üçün daha yüksək).

İndi Xcode'da yeni bir geliştirici disk imici var. Axtarış motorunu bağlayın və Xcode'yu bağlayın. Xcode'u açın və səhv yox olacaq. İndi son cihazınızı Xcodun köhnə versiyalarına qoşa bilərsiniz.

Və ya

Xcode'un ən son versiyasını yükləyə bilmirsinizsə, Xcode üçün Disk Manager'ın ən son versiyasını bu linkdən əldə edə bilərsiniz:

Xcode DMG və ya XIP faylını necə yükləyə bilərsiniz?

Onlara cavab üçün təşəkkür edirik @ Hailei. Belə ki, istifadəçilər son DMG-ni yükləyə bilərlər.

87
30 сент. Mandeep Singh tərəfindən verilmiş cavab 30 Sep 2016-09-30 09:17 '16 at 9:17 2016-09-30 09:17

Gələcəkdə də oxşar problemlər yarada biləcək insanlar üçün bu problemin əsasən iOS və Xcode versiyalarının uyğunsuzluğuna bağlı olduğuna diqqəti çəkin .

border=0

İOS və Xcode uyğunluğu yoxlayın.

572
01 нояб. cavab Santhosh Gandhe 01 noyabr. 2015-11-01 11:34 '15 'də saat 11:34 ' da

Mən şəxsən Xcode 6.4 beta və 7.0 beta versiyasını yükləmişəm və beta versiyasının 6.4 proqram qovluğunun içərisində "8.4" axtararaq bir həll tapmaqdan çox xoşbəxt oldum. Bunu edərək, iOS 8.4 şəklində olan bir qovluq 8.4 (12H4125a) və bu qovluğu beta 7.0 versiyasında eyni yolu kopyaladım. Yol belədir:

 /Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport 

Xcode 7'yi yenidən açdığınızda və cihazınızı seçərkən bir səhv mesajı görünür; yalnız fix issue basın və bunu etməlidir!

287
23 июня '15 в 23:48 2015-06-23 23:48 Cavab Nicola D tərəfindən verilir. 23 iyun '15, 23:48 2015-06-23 23:48

Bu səhv Xcode versiyası cihaz versiyası əvvəlində baş verir.

Məsələn, Xcode 7.2-də iOS 9.3-i işləyən bir qurğunun qurulmasına cəhd bu səhvdir; Could not find Developer Disk Image .

Nə baş verdiyini təsvir edən səhv mesajı niyə məndən kənarda təmin edilə bilməz (Apple, sizə baxıram).

Xcode-un ən son versiyasını App Store vasitəsilə və ya bağlı iOS avadanlığı ilə uyğunluğunu təmin etmək üçün birbaşa yükləyin .

138
16 дек. Cavab Ryan Brodi tərəfindən 16 dekabr. 2015-12-16 16:10 '15 at 16:10 2015-12-16 16:10

Köhnə Xcode istifadə edirsinizsə və iOS-nun yeni versiyası ilə qurğularda istifadə etmək istəyirsinizsə, bu hiyləni edin. Bu əsasən yeni Xcode-də köhnə Xcod üçün iOS cihaz dəstəyindən simvolik bir əlaqə yaradır.

https://gist.github.com/steipete/d9b44d8e9f341e81414e86d7ff8fb62d

Xcode 9.0 beta və iOS 11.0 beta üçün ( Xcode 9 beta üçün Xcode.app və Xcode 8 üçün Xcode9.app adını verin )

 sudo ln -s "/Applications/Xcode9.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0\ \(15A5278f\)" "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport" 
113
21 июня '16 в 12:13 2016-06-21 12:13 cavab 21 İyun 21:16 'da verilir133 2016-06-21 12:13

Mənim problemim Xcode 7 və Xcode 6.4 beta və iOS 8.4 idi - cihaz uyğunsuzdur.

Eyni problem üçün, necə düzəltmək lazım olduğunu daha yaxşı bilmək üçün aşağıdakıları edin:

  • / Proqramlar / Xcode -beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport səhifəsinə keçin
  • /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSup port /
  • İOS 8.4 qovluğunu başqa bir qovluğa köçürün

2019

109
09 июля '15 в 22:37 2015-07-09 22:37 Cavab gbk tərəfindən verilir 09 iyul '15, saat 22:37 2015-07-09 22:37

Telefonunuzda iOS 9.1 varsa, GM-i əvəzinə Xcode 7.1 beta versiyasını yükləyin.

Apple-nın cavabına baxın: iOS 9.1 üçün developers üçün disk şəklini tapa bilmədi

75
13 сент. Cavab 13 Sentyabr scurioni tərəfindən verilir 2015-09-13 04:44 '15 'də saat 4:44 ' da

Mənim cihazlarımı iOS 9.2-də yenilədikdən sonra eyni səhv başlanğıcını (geliştiriciler üçün bir disk şəkli tapa bilmədim) aldıq, ancaq Xcode 7.2-ə yüksəltməyi unutdum.

Beləliklə, mənim vəziyyətimdə düzəliş asan idi: yalnız Mac App Store vasitəsilə Xcode 7.2-ə yüksəltməyin.

61
12 дек. Cavab 12 dekabrda Philip Borges tərəfindən verilir. 2015-12-12 10:34 '15 'də saat 10:34 ' da

Xcode versiyası iOS cihazının iOS versiyası üçün çox köhnəlmişdir. Xcode-nu son versiyaya yeniləyin.

App Store Xcode üçün yenilikləri təklif etmirsə , son Mac OS-yə yüksəltməyin . Keçmişdə, Apple son Xcode-da Mac OS X-nin son versiyalarını dəstəkləməkdən imtina etməkdə olduqca təcavüzkar idi.

EDIT: Bəli, bu səhv təkrar görünməyə başladı. :) MacOS 10.11 (El Capitan) üçün ən son olan Xcode 7.3.1, iOS 10'u dəstəkləmir. Sizə MacOS Sierra (və ehtimal ki, yeni Mac) lazımdır.

41
23 дек. Cavab 23 dekabrda Seva Alekseyev tərəfindən verilir. 2015-12-23 04:24 '15 'də 4:24' de 2015-12-23 04:24

Mən bunu aldım və Xcode 7.2.1-də oldum ... Mən iOS 9.3-ə endirdikdə ortaya çıxdı. Layihə → Base SDK-nı yoxlayın və uyğun deyilsə və ya cihaz versiyasını qabaqda tutarsa, problem. Mən "Updates" bölməsində heç bir şey görmədim, amma App Store'da "Xcode" üçün axtarış apararkən 7.3 üçün yeniləmə var idi.

İOS 9.3 və Xcode 7.3-ə yüksəldilməsi Xcode- nun Mac X v10.11 (El Capitan) əməliyyatını tələb edir və dolayısı ilə avtomatik yenilənmə Xcode versiyasını yeniləmir.

24
23 марта '16 в 22:56 2016-03-23 22:56 cavab 23 mart, 22:16 , 23 mart 2016-03-23 ​​22:56 tarixində verilir

Bu məsələ iOS versiyası və Xcode versiyası arasında uyğunsuzluqdur .

Məsələn:

İOS 9.3 GM ilə iPhone və Xcode 7.2.1 versiyanız var. Bu, Xcode-i SDS və iOS 9.3-ə aid olan materialları ehtiva edən 7.3- ə yüksəlməlisiniz.

23
22 марта '16 в 22:11 2016-03-22 22:11 Cavab Məhəmməd Alqerm tərəfindən martın 22-də, 16 'da saat 10:11 ' də 2016-03-22 22:11 'də verilir

Əslində, Xcode xüsusi bir versiyası həqiqətən dəstəkləməyəcək yeni bir iOS ilə bir qurğaya yerləşdirmə yolu var. Yapmanız gereken şey, Xcode yeni versiyasından geliştirici disk imajı olan qovluğu kopyalayın.

Məsələn, bu metodu istifadə edərək, Xcode 7.2.1 istifadə edərək, iOS 9.3 çalışan bir qurğaya yerləşdirə bilərsiniz (yalnız iOS 9.2 ə qədər dəstəkləyir). Xcode 7.3 qurğusuna gedin və gedin:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

Burada, Xcode-nin köhnə versiyasında istifadə etməyə çalışdığınız versiyanı ehtiva edən qovluğu kopyalayın (bu misal üçün, brauzerlər içərisində montaj sayı ilə 9.3). Bu qovluğu Xcode'un başqa bir versiyasına kopyalayın və indi iOS-un xüsusi bir versiyasını istifadə edərək cihazı yerləşdirə bilərsiniz.

SDK nın yeni versiyasına xüsusi olaraq əlavə edilmiş API çağırışlarından istifadə edərkən, bu işləməyəcəkdir. Bu halda, Xcode'yu yeniləmək lazımdır.

16
25 марта '16 в 23:16 2016-03-25 23:16 Cavab CoBrA2168 25 mart '16 saat 23:16 2016-03-25 23:16 'də verilir

Eyni problemim vardı:

Geliştiriciler üçün disk görünüşü tapılmadı

Mənim Xcode versiyası 7.0.1 idi və mən iPhone versiyasını 9.2-ə yenilədim və Xcode istifadə etdikdən sonra bu problemə qoşuldum.

Çözüm olduqca sadədir: yalnız 8 dekabr 2015-ci ildə buraxılan Xcode 7.2-in son versiyasını yükləyin və quraşdırın. Hər şey sizin üçün yaxşıdır, əvvəlki kimi.

Qeyd Həqiqi problem Xcode versiyasının cihazınızdakı versiya ilə uyğunsuzluğundan / köhnəlməsindən ibarətdir.

12
07 янв. Cavab Aamir 07 yanvar tərəfindən verilir . 2016-01-07 09:53 '16 'da 9:53' də 2016-01-07 09:53 'da

Başqaları kimi, bu problem iOS-un uyğunsuzluğu (Xcode tərəfindən dəstəklənən maksimum versiyadan yüksəkdir) səbəb olur. Bu, genellikle Xcode'u güncelleyerek düzeltilebilir, ancaq bazen onu sınırlandırabilirsiniz, bu da başqa bir çözümdür.

dmg son Xcode dmg görüntüsünü əl ilə ələ almaq və sonra quraşdırmaq üçün developer.apple.com/downloads faylına (ya da bu link ölsə, google-benzeri maddə) müraciət edin. cp /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/NEW_IOS_VERSION /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/ , yeni Xcode sizin üçün cp /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/NEW_IOS_VERSION /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/ , lakin cp /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/NEW_IOS_VERSION /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/ Siz quraşdırdığınız köhnə cp /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/NEW_IOS_VERSION /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/ daxil istədiyiniz şəkil kopyalayın.

Əlbəttə ki, bu, gələcək versiyalarda işə zəmanət vermir, amma bu, mütləq bir cəhddir. Mənim üçün versiya iOS 9.3.1 (13E238) , amma 9.3 (13E230) kopyaladım və yaxşı işləyir.

6
10 мая '16 в 7:26 2016-05-10 07:26 Cavab verilir superarts.org May 10 '16 at 7:26 2016-05-10 07:26

Mənim vəziyyətimdə Xcode üçün 7.3-dən 7.1-ə qədər işləyirəm. İOS cihazı OS 9.2.1 üçün kataloq 9.2 kopyalayın.

6
09 февр. Cavab Pedro Castillo 09 fevralda verilir. 2016-02-09 19:14 '16 saat 07:14 'da 2016-02-09 19:14

Xcode quraşdırma çox köhnə olduğunda bu səhv göstərilir və istifadə etdiyiniz müvafiq cihaz ən son versiyaya yenilənir .

Bu problemləri həll etmək üçün bir neçə yol var.

1. Xcode quraşdırmaınızı yeniləyin.

Bu, ən asan üsuldur. Xcode quruluşunuzu ən son sabit versiyaya yüksəldin və hər şey yenidən işləyəcək.

Qeyd Xcode, mövcud OS-i dəstəkləməsə OS-i yeniləyin. Bu bizə gətirir ...

2. Cihazın görünüşünün əl ilə surəti. Yeniləmə tələb olunmur.

Bu ağıllı bir yoldur. Bunu etmək üçün, Xcode yükləməsini və ya əməliyyat sisteminizi yeniləməyə ehtiyac yoxdur.

İlk olaraq Xcode.dmg açın və Show Package Contents. İçeriğini Göstər'i seçin Show Package Contents.

Addım 1. Yüklənmiş Xcodun alınması.

Adımlar:

  • Geliştirici portalından Xcode.dmg'nin son versiyasını yükləyin.
  • İndirilen Xcode.dmg faylını seçin və sağ basın.
  • Parametrlərdə "→ DiskImageMounter ilə aç" seçin.
  • İndi Finder'da Xcode diskini açın.
  • Diskdə, Xcode üzərinə sağ basın.
  • "Paket İçindekilerini Göstər" i seçin.

İndi yeni bir axtarış pəncərəsi açılır. Disk şəklini kopyalamaq üçün aşağıdakı təlimatlara əməl edin.

Faza 2: geliştirici disk image kopyalayın.

Adımlar:

  • Yeni axtarış cihazında "Məzmun" bölməsinə keçin.
  • Məzmunun içərisində geliştiriciye keçin.
  • Geliştiricinin içərisində platformaya gedin.
    İndi istədiyiniz platforma seçin. Bizim məqsədimiz üçün yalnız iOS disk imicini yeniləyəcəyik.
  • Platforma daxilində cihaz dəstəyi bölməsinə gedin.
  • Daxili qurğular üçün dəstək, çox disk şəkillərini tapacaqsınız. Bu , cihazın son disk şəkillərini ehtiva edir.
  • Cihaz dəstəyi xidmətinin içindəki bütün qovluqları kopyalayın. Hamısını seçin və sonra kopyalayın.

Qeyd . Addım 6 üçün kopyalamaq istədiyiniz diskin surətini, yəni, kopyalayabilirsiniz. yalnız sonun surəti. Burada hiyerarşidə son qovluqdur.

Disk imicini kopyalayarak bu addımı 2 tamamlayır. İndi, növbəti addımda cihazımıza quraşdırılmış Xcode cihazının geliştiricisinin disk imicini yeniləyəcəyik.

Faza 3: Xcode geliştirici disk image aradan qaldırılması.

İndi daha sürətli iş və daha az qarışıqlıq üçün bütün axtarış pencerelerini bağlayın.

İndi iOS platforması üçün Xcode disk imicini yeniləyəcəyik.

Adımlar:

  • Xcode tətbiqini açıq olduqda bağlayın.
  • Yeni bir axtarış qutusu açın.
  • Çox bölmə varsa, əsas hissəsini seçin.
  • "Proqramlar" -a gedin.
  • Xcode tap və sağ basın.
  • "Paket İçindekilerini Göstər" i seçin.

Finder pəncərəsi yenilənir və ya əsas qovluq kimi məzmunu olan yeni bir pəncərə açır.

  1. "Məzmun" seçin.
  2. İçəridə "Geliştirici" seçin.
  3. İndi "Platformlar" seçin.
    1. İndi iPhoneOS.platformu seçin.
    2. İPhoneOS.platformu içərisində Device Support (Device Support) bölməsinə gedin.
    3. Daxili cihazları dəstəkləyin, bütün faylları seçin və zibil qutusuna gedin.

Qeyd: diskin sonuncu şəklini, yəni, hiyerarşidə son qovluğu kopyaladığınız təqdirdə 12 addım atın.


İndi, 2. mərhələdən kopyaladığımız geliştirici disk şəklini buraya qoyun.

  1. Son addım, sağ kliklə və bura vurun.

Hər şey düzgün işləsə, Xcode yeni bir geliştirici disk imicinə malikdir. Axtarış motorunu bağlayın və Xcode'u açın. Hata silinməlidir.

Xatırlatma: Xcode'u tapmaqda da unutma.

6
20 сент. Cavab Ariel tərəfindən verilir. 2016-09-20 06:03 '16 saat 06:03 'da 2016-09-20 06:03

Bu, Xcode sürümünüzün hedef OS sisteminizdə bir proqram yaratmaq üçün zəruri komponentə malik olmadığı hallarda baş verir. Xcode'yu yeniləməlisiniz .

Xcode'un sabit versiyasını yarada bilməyən OS versiyasını yeni bir tətbiq yaratdıysanız, Xcodun ən son versiyasını yükləməlisiniz .. p>

Mən də bu problemi yaşayırdım. Mən iPhone iOS 10 beta üçün Xcode 7.3 istifadə etdim, buna görə Xcode 8-beta qurmağa getdim və yeni qurma vasitəsini istifadə edərək Xcodun sabit versiyasını istifadə etməyə davam etmək üçün növbəti addımı atdım:

Xcode 8-beta yükləndikdən sonra @ onmyway133 cavabına daha çox istifadəçi dostu cavabla eyni şəkildə Xcode 7.3 ( Cmd + , ) parametrlərinə keçin, əlfəcinlərə keçin və açar listədə Xcode 8-beta ə Command Line Tools ı dəyişin.

Mən iOS 9.3 simulyatoru və iOS 10 beta cihazım üçün uğurla Xcode 7.3 istifadə edərək çalışdım.

5
24 июня '16 в 5:43 2016-06-24 05:43 cavab 24 iyun 'da FlySoFast tərəfindən 5:43 2016-06-24 05:43' də verilir

Bu problem əsasən iOS versiyası ilə Xcode versiyası arasında uyğunsuzluqla bağlıdır.

İOS və Xcode uyğunluğu yoxlayın.

Proqram qovluğuna (axtarışda) keçin → Xcode-ə sağ basın → paketin məzmununun məzmununa basın → məzmunu cütə klikləyin → iki klik qovluq → iki klik qovluq → iPhoneOS.platform qovluğuna cüt vurun → Cihaz dəstəyi qovluğunu cüt vurun → sonra ən son geliştirici disk image əlavə edin.

və ya

Xcode ən son versiyasını yükləyin.

3
04 июля '17 в 13:29 2017-07-04 13:29 Cavab Arun sharma tərəfindən verilir 4 İyul, '17 'da 13:29 2017-07-04 13:29

İOS 10 beta 7 üçün, skript satırına aşağıdakı linki əlavə edin:

 sudo ln -s /Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.0\ \(14A5339a\) /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport 
2
25 авг. 25 Avqustda Jose Galvez tərəfindən verilən cavab 2016-08-25 15:44 '16 saat 15:44 2016-08-25 15:44

Mən də bu problemə qaçdım və mən Xcode 7.2-də oldum.

İOS 9.3'ü endirdikdə göründü.

Layihə → əsas SDK yoxlayın və cihazınızın versiyasına uyğun deyilsə və ya problemi həll etmirsə.

Mən "Updates" bölməsində heç bir şey görmədim, amma App Store'da "Xcode" üçün axtarış apararkən 7.3 üçün yeniləmə var idi. İOS 9.3 və Xcode 7.3-ə yüksəldilməsi Mac OS X v10.11 (El Capitan) Xcode proqramını və niyə avtomatik yeniləmənin Xcode versiyasını yeniləməsini tələb edir.

1
04 янв. Yanvar 04-də Kumar Rakeş tərəfindən verilmiş cavab 2017-01-04 15:52 '17 da 15:52 2017-01-04 15:52

Yalnız iOS 10 üçün iki sentimə (NDA altında, lakin qanuni istifadə edə bilən insanlar üçün)

  • Tam qovluğu kopyalamaq (digər insanlar deyir) çalışır
  • Sembolik link görünmür.

Xcode 7.3 (mağazadan std) və 10.0 (14A5261v) ilə iPhone 6Plus istifadə edərək test edilmişdir.

1
16 июля '16 в 13:46 2016-07-16 13:46 cavab 16 iyun '13 'də saat 13:46' də veriləcək

Yeri gəlmişkən, bu da Xcode Sürüm 8.3.1 (8E1000a) işləyir, iOS 11-in beta versiyası üçün bir şəkil əlavə edir. İçəridə 11.0 (15A5278f) əlavə etdim

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

iOS 11-in yeni beta versiyası ilə iPhone 7plus ilə işləyir.

0
11 июня '17 в 12:19 2017-06-11 12:19 cavab 11 iyun '17 'də saat 12:19' də verildi. 2017-06-06 12:19

bağlı digər suallar və ya bir sual